XP3 will not prime

by Michael L
(Cleveland, OH)

Hello,

I have had the xp3 for a month now and I was very please with the unit over all. I took the filter apart for cleaning for the first time and now, when I release the quick release to allow for flow again, it does not pull any water from the intake. If I stop the flow again and pull out the quick release, it makes a very loud pressure release sound. Most likely that means one of the valves is being blocked, but I have checked, double checked, and triple checked all connections and everything is able to flow. How can I get my filter working again?

A: The best place to get answers to this type question is from the company/dealer where you purchased the item since they are more familiar with your setup. As an alternative you can contact the manufacturer. In the US that is Mars Fishcare (formerly Aquarium Pharmaceuticals, Inc.) This is the information in the product manual or literature that came with your product. If you don't have that information here it is again:


Email: docwellfish@aquariumpharm.com Phone: 800-847-0659




PlanetRena is an authorized distributor of Rena products and we are happy to answer questions about replacement parts or additional parts needed to complete your setup.

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to RENA Filstar XP Aquarium Filter Questions.

Order Toll-Free:
(877) 588-7362

Enter Your E-mail Address
Enter Your First Name (optional)
Then

Don't worry — your e-mail address is totally secure.
I promise to use it only to send you All Things Aquatic.